Crittografia portami via - wheezy upgrade

Forum dedicato allo sviluppo dell'e-zine di Debianizzati.Org
Rispondi
mm-barabba

Crittografia portami via - wheezy upgrade

Messaggio da mm-barabba »

Dopo diverso tempo ho voluto ripetere l' installazione sulla mia wheezy e seguendo l'articolo ho trovato alcuni errori.
Crittografia portami via - e-zine numero 0
Mi è bastato installare encfs e aggiungere il mio utente al gruppo fuse per essere nelle condizioni per poter proseguire i test.
Alla prima esecuzione del comando :

Codice: Seleziona tutto

$ encfs -v -f ~/.crypto ~/crypto
tutto procede correttamente ma nell' operazione di umount:

Codice: Seleziona tutto

$ fusermount -u crypto
fusermount: failed to access mountpoint /~/mount: Permission denied
Errore in fuse. Problemi comuni:
 - il modulo fuse del kernel non è installato (modprobe fuse)
 - opzioni non valide -- controllare l'utilizzo del comando
anche se la dir criptata viene comunque smontata.

Rirpovo un' altra volta ma un nuovo problema fà capolino :

Codice: Seleziona tutto

$ encfs -v -f ~/.crypto ~/crypto
La directory "/home/barabba/crypto" non esiste. Deve essere creata? (y/n) y
Impossibile creare la directory: : File già esistente
10:44:13 (main.cpp:422) Impossibile localizzare il punto di mount, terminato.
Build: encfs versione 1.7.4
verifico con MC e il file esiste ma è preceduto da ? e ha data 1 gennaio 1970 in più è di colore rosso (come i collegamenti rotti o i file con problemi).

Mi muovo alla ricerca nei bug (link) ma non trovo nulla di utile, così parto per una ricerca nella rete e qualcosa viene fuori.
It turns out to be a bug with the version 2.8.5-3 of libfuse2 and fuse-utils.
http://forums.linuxmint.com/viewtopic.p ... 83&start=0

Visto che non mi piace fare passi indietro decido per il passo avanti poichè in sid c'è una versione più aggiornata e assieme al mio abile pinning parto all'avventura.

Codice: Seleziona tutto

# aptitude -t unstable install libfuse2 fuse-utils fuse
I seguenti pacchetti NUOVI (NEW) saranno installati:
  libmount1{a} 
I seguenti pacchetti saranno aggiornati:
  fuse fuse-utils libfuse2 mount 
4 pacchetti aggiornati, 1 installati, 0 da rimuovere e 352 non aggiornati.
È necessario prelevare 565 kB di archivi. Dopo l'estrazione, verranno occupati 336 kB.
Continuare? [Y/n/?] 
Get:1 http://ftp.ch.debian.org/debian/ sid/main libmount1 i386 2.19.1-4 [110 kB]
Get:2 http://ftp.ch.debian.org/debian/ sid/main mount i386 2.19.1-4 [204 kB]
Get:3 http://ftp.ch.debian.org/debian/ sid/main fuse i386 2.8.5-4 [65,9 kB]
Get:4 http://ftp.ch.debian.org/debian/ sid/main libfuse2 i386 2.8.5-4 [146 kB]
Get:5 http://ftp.ch.debian.org/debian/ sid/main fuse-utils all 2.8.5-4 [39,0 kB]
diversi pacchetti passano dalla versione 2.8.5-3 a 2.8.5-4.

Eseguo di nuovo le prove e finalmente tutto funziona correttamente senza errori , sia il mount che l'umount.
Ora però ho alcune questioni da porvi :

1) come avvertire gli sviluppatori e che pacchetto incriminare ?
2) siete a conoscenza di possibili problemi o bug legati ai pacchetti che ho aggiornato ?

grazie per l' attenzione se siete arrivati fino a qui O0
Aki
Global Moderator
Global Moderator
Messaggi: 9967
Iscritto il: 27/12/2007, 16:59

Re: Crittografia portami via - wheezy upgrade

Messaggio da Aki »

Ciao,
mm-barabba ha scritto:[..]come avvertire gli sviluppatori e che pacchetto incriminare ?
Potresti aggiungere un ulteriore report alla segnalazione già presente nel BTS specificando la soluzione che hai trovato. Il pacchetto interessato, ammesso che sia effettivamente quello interessato, è già collegato al bug report. Se altri pacchetti sono interessati, potrebbero essere desunti dai log che hai prodotto.

Aki.
⢀⣴⠾⠻⢶⣦⠀
⣾⠁⢠⠒⠀⣿⡁ Debian - The universal operating system
⢿⡄⠘⠷⠚⠋⠀ https://www.debian.org
⠈⠳⣄⠀
mm-barabba

Re: Crittografia portami via - wheezy upgrade

Messaggio da mm-barabba »

ci ho provato nel mio pessimo inglese senza l' aiuto di 'google translator'
speriamo sia utile.
:-\
il link del bug è quello precedentemente indicato.
skizzhg

Re: Crittografia portami via - wheezy upgrade

Messaggio da skizzhg »

google translator è in grado di fare molto peggio ;)

piccolo suggerimento, visti gli ovvi "problemi" dovuti alla localizzazione del sistema in lingue diverse dall'inglese, quando devi segnalare cose simili esporta una lingua neutra in quel terminale:

Codice: Seleziona tutto

 $ export LANG=C 
poi esegui tutti i comandi che ti servono.
mm-barabba

Re: Crittografia portami via - wheezy upgrade

Messaggio da mm-barabba »

skizzhg ha scritto:google translator è in grado di fare molto peggio
lo dice anche pmate di non fidarsi di google :P

grazie per il consiglio
ma ho già eseguito l' upgrade su tutte le macchine interessate
terrò a mente per il futro ;)
Rispondi