problema installazione epsxe

Giocare con Debian. Sezione dedicata all'installazione, alla configurazione e all'utilizzo dei giochi sotto Linux
Rispondi
Synapse97
Newbie
Newbie
Messaggi: 33
Iscritto il: 15/01/2016, 0:10

problema installazione epsxe

Messaggio da Synapse97 »

ho seguito passo dopo passo le seguente guida http://guide.debianizzati.org/index.php ... laystation ma quando do l'ultimo comando per lanciare il programma mi esce fuori questo errore: (./epsxe: error while loading shared libraries: libXt.so.6: cannot open shared object file: No such file or directory)
sapreste indicarmi come risolvere?
Aki
Global Moderator
Global Moderator
Messaggi: 9941
Iscritto il: 27/12/2007, 16:59

Re: problema installazione epsxe

Messaggio da Aki »

Prova ad installare il pacchetto di cui trovi i riferimenti all'indirizzo https://packages.debian.org/stretch/libxt6
Synapse97
Newbie
Newbie
Messaggi: 33
Iscritto il: 15/01/2016, 0:10

Re: problema installazione epsxe

Messaggio da Synapse97 »

Già fatto, medesimo risultato
Avatar utente
mark
Hero Member
Hero Member
Messaggi: 802
Iscritto il: 10/01/2007, 16:53

Re: problema installazione epsxe

Messaggio da mark »

se questa informazione è aggiornata
https://wiki.debian.org/it/Emulator
ePSXe (non-free, solo i386)
probabilmente ti serve la versione 386 della libreria

in alternativa vedi qui:
ePSXe64Ubuntu - also supporting Debian
- an interactive script that installs ePSXe 2.0.5 Linux x64
https://github.com/brandleesee/ePSXe64Ubuntu
tieni presente però che non ho verificato la funzionalità di questo script
Avatar utente
Debianello
Jr. Member
Jr. Member
Messaggi: 67
Iscritto il: 27/05/2011, 6:43

Re: problema installazione epsxe

Messaggio da Debianello »

Ciao Synapse97,

se posso darti un consiglio, e se hai un processore abbastanza veloce (un dual core più o meno recente ad almeno 2.40 GHz dovrebbe andare bene per la maggior parte dei giochi), ti consiglierei di utilizzare Mednafen come emulatore, che offre un'emulazione più fedele della PlayStation. Emulatori meno accurati come ePSXe o PCSX-Reloaded, a mio avviso, ha senso usarli solo quando l'emulazione con Mednafen risulta lenta.
A proposito di Mednafen, se stai usando Debian stable, fossi in te compilerei l'emulatore, anziché installarlo da repository, così da avere l'ultima versione (attualmente 1.21.3).

In ogni caso, se non hai un buon processore per Mednafen, ti consiglio PCSX-Reloaded (puoi installarlo dal pacchetto “pcsxr” che trovi nel repository di Debian). Tra gli emulatori meno accurati, personalmente lo considero il migliore, ed è quello che utilizzavo un tempo, prima che venisse rilasciato il modulo psx di Mednafen.

P.S.: visto che alla fine gli emulatori di console si usano per giocare, questa discussione non andrebbe in Giochi?
mednafen-it - Gruppo di utenti italiani di Mednafen. Si organizzano anche partite online, sempre con Mednafen!
Aki
Global Moderator
Global Moderator
Messaggi: 9941
Iscritto il: 27/12/2007, 16:59

Re: problema installazione epsxe

Messaggio da Aki »

Debianello ha scritto:P.S.: visto che alla fine gli emulatori di console si usano per giocare, questa discussione non andrebbe in Giochi?
Intervento di moderazione: discussione spostata nella sezione "Giochi".
brandleesee
Newbie
Newbie
Messaggi: 1
Iscritto il: 30/06/2018, 14:32

Re: problema installazione epsxe

Messaggio da brandleesee »

Salve ragazzi, sono il developer di ePSXe64Ubuntu.

Volevo fare notare che le istruzioni in questo link sono per una versione molto antica ed e' allora possibile che le dipendenze sono cambiati:
http://guide.debianizzati.org/index.php ... laystation

Allora suggerisco che si utilizzano questi comandi che usano la ultima versione di ePSXe (2.0.5)

Architettura x86 (32)

Codice: Seleziona tutto

wget http://www.epsxe.com/files/ePSXe205linux.zip

mkdir psx

cd psx

unzip /home/$USER/ePSXe205linux.zip

wget http://www.pbernert.com/gpupetexgl206.tar.gz

wget http://www.pbernert.com/cdrpeops104.zip

wget http://www.pbernert.com/spupeopsoss109.tar.gz

cd $HOME/psx/plugins

unzip $HOME/cdrpeops104.zip

tar xvfz $HOME/spupeopsoss109.tar.gz

cd $HOME

mkdir video

cd video

tar xvfz $HOME/video/gpupetexgl206.tar.gz

mv gpuPeteXGL2.cfg $HOME/psx

mv cfgPeteXGL2 $HOME/psx

mv libgpuPeteXGL2.so.2.0.6 $HOME/plugins
Architettura x86_64 (x64)

Codice: Seleziona tutto

wget http://www.epsxe.com/files/ePSXe205linux_x64.zip

mkdir psx

cd psx

unzip /home/utente/ePSXe205linux_x64.zip
Notamenti
  • ho dubio sulla logica e cronologia dei comandi (quando gli paragono alla mia script)
  • ePSXeCutor non lo messo per nessuna arcitettura perche' non l'ho mai usato
  • in architettura x64 i plugin di Pete non funzionano.
  • suggerisco di usare il built-in BIOS: HLE (High Level Emulation)
  • per evitare problemi Overclocking deve essere sempre x1 (Options --> CPU overclocking)
ePSXe64Ubuntu
https://github.com/brandleesee/ePSXe64Ubuntu/

Altrimenti, se il computer e' di architettura x64 si puo usare la mia script:

Codice: Seleziona tutto

wget -O ePSXe64Ubuntu.sh https://raw.githubusercontent.com/brandleesee/ePSXe64Ubuntu/master/ePSXe64Ubuntu.sh

bash ePSXe64Ubuntu.sh
Tengo molto a questo emulatore.
Spero che sono stato di aiuto.
Tanti saluti!
Rispondi